Topklasse Discussion Board  
Home Forum Legal/Privacy Media/Picture Gallery Websites and Links Technical

Go Back   Topklasse Discussion Board > THE EXPERIENCE - DRIVING PLEASURE > MERCEDES W116

MERCEDES W116 Discussion specific to the W116 model

Reply
 
Thread Tools Display Modes
  #1  
Old 9th January 2013, 09:16 PM
CraigS's Avatar
CraigS CraigS is offline
Connoisseur
 
Join Date: Apr 2008
Location: Sydney
Posts: 692
Default 6.9 # 7114 - it lives !

Since almost every other car I own is in various stages of repairs, or waiting on parts, I decided to try to get my 6.9 running again. I have not started it for probably 2 years. I bought a new battery, some fresh gas, and a small amount of gas down the intake, and woof - away she went. It idles quite well, but isn't too happy when you try to rev it. Seems to be not getting enough gas. The fuel pump flow is fine, so I suspect either fuel distributor needs a clean and possibly the filter inside the fuel inlet, but I could also be completely wrong about this.

The rear suspension is also not coming up, so I am hoping it is only the linkage that has come off. Will check at the weekend.

For those that have never seen it, here are a couple of photos.





Reply With Quote
  #2  
Old 9th January 2013, 10:02 PM
BenzBoy BenzBoy is offline
Noble
 
Join Date: Feb 2008
Location: Sydney - Centre of Civilisation
Posts: 6,425
Default Re: 6.9 # 7114 - it lives !

Looks to be in damned good condition - and a great colour combination Craig.
Regards,
Brian
Reply With Quote
  #3  
Old 9th January 2013, 10:12 PM
260ebenz's Avatar
260ebenz 260ebenz is offline
300sebenz
 
Join Date: Dec 2009
Location: NSW
Posts: 6,381
Default Re: 6.9 # 7114 - it lives !

Craig very nice 6.9 you have there!

I can see an Adenauer in the pic as well.

Velour seats as well.

All the best with car Craig.

Last edited by 260ebenz; 9th January 2013 at 10:15 PM.
Reply With Quote
  #4  
Old 10th January 2013, 06:21 AM
Michel's Avatar
Michel Michel is offline
One Of The Boys
 
Join Date: Feb 2008
Location: Sydney, Australia
Posts: 8,488
Default Re: 6.9 # 7114 - it lives !

One car I have always admired.

Good luck with it Craig.

It deserves to be on the road often.
__________________
Michel

1978 W116 690SEL # 3312
1985 R107 500SL AMG
2000 W208 CLK430 Coupe
2003 W163 ML320
Reply With Quote
  #5  
Old 10th January 2013, 06:54 AM
CraigS's Avatar
CraigS CraigS is offline
Connoisseur
 
Join Date: Apr 2008
Location: Sydney
Posts: 692
Default Re: 6.9 # 7114 - it lives !

Yes, that is my 300b. Another one that is currently immobile, but new custom made pistons arrive on the 18th of this month and I can get it back on the road soon.

This 6.9 was a Stuttgart delivery, and hence has the Euro engine, optioned with velour, no sunroof, and the badge delete option.

Quote:
Originally Posted by 260ebenz View Post
Craig very nice 6.9 you have there!

I can see an Adenauer in the pic as well.

Velour seats as well.

All the best with car Craig.
Reply With Quote
  #6  
Old 10th January 2013, 07:46 AM
CraigS's Avatar
CraigS CraigS is offline
Connoisseur
 
Join Date: Apr 2008
Location: Sydney
Posts: 692
Default Re: 6.9 # 7114 - it lives !

Don't know what happened to your post Styria - I can't see it below, but I received an email notification that you posted.

Yes, the car is in Sydney and has been for quite a long time, and yes, it is the one I pipped Michel at the post ! You are more than welcome to come over. I will be on holiday next week and around Sydney before going to Brisbane the following week to work on the 300b and the Tatraplan - who said holiday !

To be fair, the 6.9 was on eBay and ended on Christmas Eve 2006, so I think I was fortunate in that regard - both for the price I paid, and that Michel must have been busy !

If anyone happens to have a W116 fuel tank they don't want, I would be most appreciative. I am not completely certain mine is good, so would prefer to change it before I go trouble shooting the fuel supply problem.
Reply With Quote
  #7  
Old 10th January 2013, 08:20 AM
Oversize's Avatar
Oversize Oversize is offline
Aristocrat
 
Join Date: Apr 2010
Location: Melbourne
Posts: 4,034
Default Re: 6.9 # 7114 - it lives !

Oh what a lovely car Craig! What's the colour called and the code? Badge delete (factory) seems quite rare....

When you sort the rear suspension and rule out there's nothing nasty in the tank, you may find some injector cleaner and an Italian tune-up will do the trick!
__________________
Mark

01 Ford AU 5L (Deep Blue)
89 560L#322020
88 500L#451660-P
88 420L#422477-P
87 420L#324309-P
87 420L#-P
88 420L Euro#-P
88 420L#-P
86 560L#235896-P
79 6.9#5541 (Red Bull)
79 6.9#5398-P
78 6.9#4248 (Skye)-P
79 6.9#3686 (Moby Dick)
78 6.9#1776 (Dora)
77 450L#067010-P
75 450L#028414 (Gold Nugget)-P
57 Buick 73A (Titanic)
Reply With Quote
  #8  
Old 10th January 2013, 08:21 AM
Oversize's Avatar
Oversize Oversize is offline
Aristocrat
 
Join Date: Apr 2010
Location: Melbourne
Posts: 4,034
Default Re: 6.9 # 7114 - it lives !

Oh and do you have any pix of the dash and the engine? Did she require much work after you bought it?
__________________
Mark

01 Ford AU 5L (Deep Blue)
89 560L#322020
88 500L#451660-P
88 420L#422477-P
87 420L#324309-P
87 420L#-P
88 420L Euro#-P
88 420L#-P
86 560L#235896-P
79 6.9#5541 (Red Bull)
79 6.9#5398-P
78 6.9#4248 (Skye)-P
79 6.9#3686 (Moby Dick)
78 6.9#1776 (Dora)
77 450L#067010-P
75 450L#028414 (Gold Nugget)-P
57 Buick 73A (Titanic)
Reply With Quote
  #9  
Old 10th January 2013, 09:00 AM
CraigS's Avatar
CraigS CraigS is offline
Connoisseur
 
Join Date: Apr 2008
Location: Sydney
Posts: 692
Default Re: 6.9 # 7114 - it lives !

Paint code is 581 - Inca Rot (Inca Red). As far as I know, this is the only one in this colour - or at least, I have never seen another 6.9 in this colour. It was on some W123's, but again, not common.

When I bought it in 2006, it had not been run for about 4 years. The previous owner was a Qantas engineer and he had back trouble and was on compo, so couldn't drive it. It had water in the petrol and that caused a number of problems. Once the pump, filters/accumulators had been changed a number of times, it seemed to come right, but then I put it into storage and it basically sat again for some time. The suspension had never been a problem, which is why I suspect that the linkage has come off.

I don't think it will take too much to get it running right again. I have another fuel distributor, so will change that, and I also have another WUR, but not sure about the condition of that, so may leave changing that at this stage.

Pictures of the dash and engine below.





http://s109.beta.photobucket.com/use...02016.jpg.html
Reply With Quote
  #10  
Old 10th January 2013, 06:25 PM
Helmet Helmet is online now
Aristocrat
 
Join Date: Oct 2011
Location: Sydney
Posts: 1,107
Default Re: 6.9 # 7114 - it lives !

A stunner Craig. Inka red with cream velour and looks in great nic
Reply With Quote
  #11  
Old 10th January 2013, 07:21 PM
CraigS's Avatar
CraigS CraigS is offline
Connoisseur
 
Join Date: Apr 2008
Location: Sydney
Posts: 692
Default Re: 6.9 # 7114 - it lives !

I fixed the suspension today. It was just the linkage that had come adrift, so I installed a new rod and it is back to normal - albeit that it will need a slight bit of tweaking to get the height exact.
Reply With Quote
  #12  
Old 10th January 2013, 07:30 PM
260ebenz's Avatar
260ebenz 260ebenz is offline
300sebenz
 
Join Date: Dec 2009
Location: NSW
Posts: 6,381
Default Re: 6.9 # 7114 - it lives !

Craig how many miles on the clock?
Reply With Quote
  #13  
Old 10th January 2013, 07:42 PM
CraigS's Avatar
CraigS CraigS is offline
Connoisseur
 
Join Date: Apr 2008
Location: Sydney
Posts: 692
Default Re: 6.9 # 7114 - it lives !

243,000km
Reply With Quote
  #14  
Old 10th January 2013, 11:25 PM
SEL_69L's Avatar
SEL_69L SEL_69L is offline
Aristocrat
 
Join Date: Feb 2009
Location: Sydney, NSW, Australia
Posts: 1,115
Default Re: 6.9 # 7114 - it lives !

If the engine is having a bit of trouble running properly, I would guess that the whole fuel delivery system tank to injectors, could do with a clean out. Especially so, it the car has been standing idle for some years.

When you get a mixture of air, water and fuel standing for a long time, there a few species bacteria that can breed up and can cause suspended flocking in the fuel. These flocks can block filters and injectors.

The injectors should also be checked for delivery rate and spray pattern. If there has been any water about, rust in the injectors can be a problem. Fortunately, mechanical injectors are a hell of a lot cheaper to replace than electronic ones. The injector that is used in the 6.9 is common to lot of other European cars of this of this era. Volvo injectors of this period for example, are identical.

A huge amount of effort is expended on maintaining the quality control with aircraft fuel, be it avgas or avtur (JP4). Water condensation and flocking are the enemies.

The fuel filter farm at RAAF Richmond is very comprehensive.
Reply With Quote
  #15  
Old 11th January 2013, 09:12 AM
Oversize's Avatar
Oversize Oversize is offline
Aristocrat
 
Join Date: Apr 2010
Location: Melbourne
Posts: 4,034
Default Re: 6.9 # 7114 - it lives !

I'm glad you sorted out the suspension and I agree it might be a good idea to flush the tank and replaced the fuel filter. Add injector cleaner and see how she goes then.

And now it's time for an oil and coolant change.... Don't forget the brake fluid too.
__________________
Mark

01 Ford AU 5L (Deep Blue)
89 560L#322020
88 500L#451660-P
88 420L#422477-P
87 420L#324309-P
87 420L#-P
88 420L Euro#-P
88 420L#-P
86 560L#235896-P
79 6.9#5541 (Red Bull)
79 6.9#5398-P
78 6.9#4248 (Skye)-P
79 6.9#3686 (Moby Dick)
78 6.9#1776 (Dora)
77 450L#067010-P
75 450L#028414 (Gold Nugget)-P
57 Buick 73A (Titanic)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AAB-007 lives on! Tony66_au MERCEDES W116 54 15th December 2011 10:42 PM


All times are GMT +10. The time now is 05:35 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright Topklasse 2017