Topklasse Discussion Board  
Home Forum Legal/Privacy Media/Picture Gallery Websites and Links Technical

Go Back   Topklasse Discussion Board > THE CRAFTSMAN - TECHNICAL DEPARTMENT > MECHANICALS

MECHANICALS With a 30 year-old automobile, there will always be discussion here - maintenance, modifications and mechanicals.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 16th February 2018, 04:46 PM
6.9forever's Avatar
6.9forever 6.9forever is offline
Aficionado
 
Join Date: Feb 2008
Location: Sunshine Coast
Posts: 240
Default Australian 6.9 low in rear but OK in front; also goes to High position at front

Hi All -

I've been away for 3 weeks and came back to a very low rear end on the 6.9 (left and right).

When idling, it maintains normal height in the front (even left and right) and also responds to the raised H position at the front only.

There's no leak from back struts so I wonder if the back valve has stopped working while unused for that 3 week period? Or is it another easy fix?

Any help on the initial approach to the problem would be appreciated before I insert blocks and tow to workshop.

Thanks and regards.
__________________
David
______________________________
450SEL6.9 - #4811 Classic White/Parchment velours, AUS delivered 1978
450SLC - Citrus Green/Parchment leather, AUS delivered 1979
C200 (W205) - 2015
B200 (W246) - 2015
______________________________
Reply With Quote
  #2  
Old 16th February 2018, 05:28 PM
Helmet Helmet is offline
Aristocrat
 
Join Date: Oct 2011
Location: Sydney
Posts: 1,145
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

Hi David, first thing to check is that the link is attached to the rear level valve . May have broken the plastic ball joint
Reply With Quote
  #3  
Old 16th February 2018, 05:39 PM
Oversize's Avatar
Oversize Oversize is offline
Aristocrat
 
Join Date: Apr 2010
Location: Melbourne
Posts: 4,266
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

If the fluid's dirty or has't been changed in years it could be a blockage. If not it'll probably be leak-back through the rear valve since the problem is common to both struts. Carefully try bleeding the system at the rear valve and see what you get.
__________________
Mark

01 Ford AU 5L (Deep Blue)
89 560L#322020
88 500L#451660-P
88 420L#422477-P
87 420L#324309-P
87 420L#-P
88 420L Euro#-P
88 420L#-P
86 560L#235896-P
79 6.9#5541 (Red Bull)
78 6.9#4248 (Skye)
79 6.9#3686 (Moby Dick)
78 6.9#1776 (Dora)
77 450L#067010-P
75 450L#028414 (Gold Nugget)-P
57 Buick 73A (Titanic)
Reply With Quote
  #4  
Old 17th February 2018, 04:50 PM
6.9forever's Avatar
6.9forever 6.9forever is offline
Aficionado
 
Join Date: Feb 2008
Location: Sunshine Coast
Posts: 240
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

Thank you both.
Peter: I've checked link - it's intact.
Mark: I suspect dirty fluid. I will probably start with a drain/flush/refill, before tackling any hardware.
Cheers.
__________________
David
______________________________
450SEL6.9 - #4811 Classic White/Parchment velours, AUS delivered 1978
450SLC - Citrus Green/Parchment leather, AUS delivered 1979
C200 (W205) - 2015
B200 (W246) - 2015
______________________________
Reply With Quote
  #5  
Old 17th February 2018, 05:16 PM
Styria's Avatar
Styria Styria is offline
The Godfather
 
Join Date: Feb 2008
Location: Sydney
Posts: 8,162
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

Hi David, sorry to be a little slow in responding. Short of checking the system with pressure gauges, one can start checking some functions by undoing various plugs and/or piping to determine if there is pressure, or if there is an air lock.

Am I right in assuming that the aircells have recently been renewed ? If so, the system has probably been disturbed to some degree. First of all, disconnect the wire cable from the disc sitting atop the distribution valve. Ensure that there is resistance when you move the disk from normal to static position, and then to the high position and back again. There must be resistance.

Next step is to undo the 12mm plug that's attached to the control valve on top of the reservoir. Initially, with engine turned off, remove that closing plug, withdraw the very small gauze filter that's behind the plug and check the interference fit of the rubber 'O' ring that is attached to the plug. Once you have cleaned the filter, replace refit plug and tighten firmly. Start engine, observe operation of disc (there should be resistance when turning), and slightly undo that closing plug - not by much, observe if pressurized hydraulic oil will want to spurt out, and if it is, retighten that closing plug whilst engine is still running. Try and take the car for a drive in the hope that suspension movement will " wake up" the system and rtaise the rear level back to its normal height. Of course, please feel free to phone me. Best of luck, Styria.
Reply With Quote
  #6  
Old 17th February 2018, 05:33 PM
6.9forever's Avatar
6.9forever 6.9forever is offline
Aficionado
 
Join Date: Feb 2008
Location: Sunshine Coast
Posts: 240
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

Thank you, Michael.

I'm packing to travel again in the morning but will be able to lift the bonnet/hood again on Friday and try this out. There used to be good resistance when turning the disk atop the reservoir. Now there isn't. I had noticed this only recently and wondered aloud if this suggested a fluid problem. No, I haven't replaced the cells yet, although they must be done. Firstly I have to get the old girl up off my garage floor; my younger neighbour thinks it looks "wicked" in its current stance! (there is currently 3/4" clearance under the intermediate silencer!).

She turns 40 in August and I am planning a party with lots of presents (accumulator cells, new tyres, air-cond regas etc.!).

Your sage words are, as always, much appreciated.

I'll keep you posted.

Cheers.
__________________
David
______________________________
450SEL6.9 - #4811 Classic White/Parchment velours, AUS delivered 1978
450SLC - Citrus Green/Parchment leather, AUS delivered 1979
C200 (W205) - 2015
B200 (W246) - 2015
______________________________
Reply With Quote
  #7  
Old 18th February 2018, 02:21 PM
Michel's Avatar
Michel Michel is offline
One Of The Boys
 
Join Date: Feb 2008
Location: Sydney, Australia
Posts: 8,514
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

I had the same problem with the Red Terror.
Parked untouched for a few weeks and the back is down.
Check the disk and it turns with no clicks and no reaction.
I drive it around the block and left it idle for 20min after and nothing changed.
So I parked Friday week and left it it hoping Styria would come the next week and have a look.
Monday morning I come to work and the back is up in itís normal position! 😳
__________________
Michel

1978 W116 690SEL # 3312
1985 R107 500SL AMG
2000 W208 CLK430 Coupe
2003 W163 ML320
Reply With Quote
  #8  
Old 19th February 2018, 08:19 AM
Styria's Avatar
Styria Styria is offline
The Godfather
 
Join Date: Feb 2008
Location: Sydney
Posts: 8,162
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

The vagaries of the 6.9 hydraulic suspension system can be numerous and, more often than not, frustrating. I have always maintained that a 6.9 ought to be used from time to time just to keep "things on the boil", but even then one can be left frustrated in working out the system. 6.9s are now, and have been for quite a while, in the situation that anyone component singularly or perhaps in tandem with other components of the system, can leave you stranded, scratching your head, and causing frustration.

For a long time now I have been rebuilding some of the hydraulic components, with a better than reasonable success ratio. I have done this on a hobby type basis, and a number of my endeavours have been dictated by the need to keep my own "Gleaming Beauty" mobile for the last twenty two years - may even be 23. There are other rebuilders in Sydney, but one 6.9 (David Rollason's) has found its way to a very well known repair business with a wealth of experience going back thirty five years - and I am not talking about our Helmet (Peter). They have been confronted with purportedly slightly weeping front and rear valves, and that repair shop recommended replacement of those valves. Now, I repeat this repair shop bristles with Mercedes experience and suggested to the owner that the valves be sent to Melbourne for rebuilding.

The fact now is that the valves have been returned by their Victorian source advising them that they are unable to carry out the work. They simply don't know how to. So, the suggestion was forwarded that they now be sent to the States, and that's where the owner decided to contact me. As far as I am concerned, that repair shop should not have removed those valves and now rendering the car to attain the status of "VOR", especially as they had no idea of how to deal with the problem. From a personal point of view, I am reluctant to attend to this work as it still involves the repair shop to effect fitting of the valves and getting the car going. My preference is for me to do everything, for the simple reason that even if perfectly operational valves are fitted, the system can still be troublesome. Once you disturb the system, anything is likely to malfunction simply because many components are quite old and inclined to interfere with the proper operation of the hydraulics. All this is a bit long winded, but I can assure you that at one stage it took two of us two days to get the system to raise a car to its recommended height. Regards Styria

Last edited by Styria; 19th February 2018 at 08:22 AM.
Reply With Quote
  #9  
Old 5th August 2018, 03:04 PM
6.9forever's Avatar
6.9forever 6.9forever is offline
Aficionado
 
Join Date: Feb 2008
Location: Sunshine Coast
Posts: 240
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

Today was a day of discovery.
My 6.9 has sat on the floor for a while now in a very confined space while I was so caught up (and still am) in work-related pressures that are unrelenting, with business travel and a legal case thrown in as well.
I carved out time on this Sunday to clear all the stuff around the car and jack up the rear.
Sure enough, (and contrary to what I previous thought), Helmet was correct back in February.
The rear levelling valve connecting rod has disconnected due to crumbled plastic ball joints at each end. No wonder the rear wouldn't come up, although after sustained effort, the front has. So relieved.
Now to fit the new spheres that I have promised to purchase as well.
__________________
David
______________________________
450SEL6.9 - #4811 Classic White/Parchment velours, AUS delivered 1978
450SLC - Citrus Green/Parchment leather, AUS delivered 1979
C200 (W205) - 2015
B200 (W246) - 2015
______________________________
Reply With Quote
  #10  
Old 8th August 2018, 05:16 PM
Oversize's Avatar
Oversize Oversize is offline
Aristocrat
 
Join Date: Apr 2010
Location: Melbourne
Posts: 4,266
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

Great news!
__________________
Mark

01 Ford AU 5L (Deep Blue)
89 560L#322020
88 500L#451660-P
88 420L#422477-P
87 420L#324309-P
87 420L#-P
88 420L Euro#-P
88 420L#-P
86 560L#235896-P
79 6.9#5541 (Red Bull)
78 6.9#4248 (Skye)
79 6.9#3686 (Moby Dick)
78 6.9#1776 (Dora)
77 450L#067010-P
75 450L#028414 (Gold Nugget)-P
57 Buick 73A (Titanic)
Reply With Quote
  #11  
Old 12th August 2018, 06:47 PM
6.9forever's Avatar
6.9forever 6.9forever is offline
Aficionado
 
Join Date: Feb 2008
Location: Sunshine Coast
Posts: 240
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

New rear connecting rod fitted to levelling valve block and torsion bar. Car rose up! Now to purchase promised spheres.
__________________
David
______________________________
450SEL6.9 - #4811 Classic White/Parchment velours, AUS delivered 1978
450SLC - Citrus Green/Parchment leather, AUS delivered 1979
C200 (W205) - 2015
B200 (W246) - 2015
______________________________
Reply With Quote
  #12  
Old 16th August 2018, 06:40 PM
6.9forever's Avatar
6.9forever 6.9forever is offline
Aficionado
 
Join Date: Feb 2008
Location: Sunshine Coast
Posts: 240
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

Here 'tis. And the post-fit reward!
Attached Images
File Type: jpg 20180811_155404.jpg (374.7 KB, 9 views)
File Type: jpg 20180811_172751.jpg (709.2 KB, 8 views)
File Type: jpg 20180811_175424.jpg (279.2 KB, 6 views)
__________________
David
______________________________
450SEL6.9 - #4811 Classic White/Parchment velours, AUS delivered 1978
450SLC - Citrus Green/Parchment leather, AUS delivered 1979
C200 (W205) - 2015
B200 (W246) - 2015
______________________________

Last edited by 6.9forever; 16th August 2018 at 11:20 PM.
Reply With Quote
  #13  
Old 17th August 2018, 06:18 PM
Oversize's Avatar
Oversize Oversize is offline
Aristocrat
 
Join Date: Apr 2010
Location: Melbourne
Posts: 4,266
Default Re: Australian 6.9 low in rear but OK in front; also goes to High position at front

Brilliant!! FYI there might be another cell supplier in Sydney, but Iíve yet to give them a call to check prices or availability...
__________________
Mark

01 Ford AU 5L (Deep Blue)
89 560L#322020
88 500L#451660-P
88 420L#422477-P
87 420L#324309-P
87 420L#-P
88 420L Euro#-P
88 420L#-P
86 560L#235896-P
79 6.9#5541 (Red Bull)
78 6.9#4248 (Skye)
79 6.9#3686 (Moby Dick)
78 6.9#1776 (Dora)
77 450L#067010-P
75 450L#028414 (Gold Nugget)-P
57 Buick 73A (Titanic)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
6.9 Front/Rear Struts Styria TRADING POST/EBAY LISTINGS 3 9th March 2012 09:49 AM
Slotted Discs - Front and Rear for 116 Styria TRADING POST/EBAY LISTINGS 29 18th October 2008 04:13 AM
Front Bush replacement on Rear Subframe WGB MECHANICALS 5 5th July 2008 11:54 AM
Front and Rear Door Trims Styria INTERIORS 9 10th April 2008 09:36 AM
Front and Rear Subframe rubbers WGB MECHANICALS 6 11th March 2008 05:37 AM


All times are GMT +10. The time now is 10:01 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright Topklasse 2017