Topklasse Discussion Board  
Home Forum Legal/Privacy Media/Picture Gallery Websites and Links Technical

Go Back   Topklasse Discussion Board > THE EXPERIENCE - DRIVING PLEASURE > MERCEDES W107

MERCEDES W107 Discussion specific to the W107 model

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 20th October 2015, 08:59 PM
Tony R Tony R is offline
Respectable
 
Join Date: Oct 2015
Location: Darwin NT
Posts: 5
Default 280 SL (107) slight engine miss

My 107 280 SL has a really strong motor that starts first time and idles nicely.Most of the time it accelerates fine and cruises at speed well however it sometimes has a miss (slight hesitation) under acceleration or at speed. Ive changed the spark plugs, installed bosch ignition leads and new distributor cap and a new fuel filter. I thought I would start with the easy things first however the issue is still there. Im running the car on premium unleaded which the car seems to like. The engine never feels like its going to stop - its more annoying than anything. Has anyone experienced this with their 6 cylinder engine ? Im wondering if it could be related to the fuel injection system in some way? Any ideas?
Cheers
Tony R
__________________
Tony R

1975 280 SL(Sunshine)
1979 450 SEL 6.9(Blue Flame)
Reply With Quote
  #2  
Old 21st October 2015, 07:18 AM
sean sherry sean sherry is offline
Aristocrat
 
Join Date: Jan 2012
Location: sydney
Posts: 1,122
Smile Re: 280 SL (107) slight engine miss

A K Jetronic System Tony ??
Perhaps the injection System . Though a define miss may well be an ignition issue. No easy answer. The fuel sounds ok. But a pressure and leakage test for the metering Head and the Warm up Regulator will tell. Also the injectors and or their seals. A culprit could be the Ignition Module. I have a spare one from my own 1981 280 Sl that you are welcome to try.
Sometimes substitution is the easiest way to go.
Reply With Quote
  #3  
Old 26th October 2015, 09:07 PM
Tony R Tony R is offline
Respectable
 
Join Date: Oct 2015
Location: Darwin NT
Posts: 5
Default Re: 280 SL (107) slight engine miss

Thanks for the response sean !
Ill have a look into these suggestions and see how I go
__________________
Tony R

1975 280 SL(Sunshine)
1979 450 SEL 6.9(Blue Flame)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hot starting miss sean sherry MERCEDES W107 1 23rd April 2012 08:50 PM
Miss During Warm Up Michel MECHANICALS 5 21st April 2010 03:13 AM
Miss Olga would not approve? Des TALKING TORQUE 6 13th August 2008 08:33 AM


All times are GMT +10. The time now is 10:47 AM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright Topklasse 2017