Topklasse Discussion Board  
Home Forum Legal/Privacy Media/Picture Gallery Websites and Links Technical

Go Back   Topklasse Discussion Board > THE EXPERIENCE - DRIVING PLEASURE > MERCEDES W126

MERCEDES W126 The W126 S Class saloon and coupe from 1979-1992 (260SE, 280S, 280SE, 280SEL, 300SD, 300SDL, 300SE, 300SEL, 350SD, 350SDL, 380SE, 380SEL, 380SEC, 420SE, 420SEL, 420SEC, 500SE, 500SEL, 500SEC, 560SE, 560SEL, 560SEC)

Reply
 
Thread Tools Search this Thread Display Modes
  #61  
Old 30th May 2019, 04:42 PM
Michel's Avatar
Michel Michel is offline
The Prince of Arabia
 
Join Date: Feb 2008
Location: Sydney, Australia
Posts: 8,951
Default Re: 560sec ece

Quote:
Originally Posted by c107 View Post
More than 24 hours later the English mustard seems to have bonded the pad to the underside of the bonnet quite well.

I will repeat this same procedure with the 300SE, which is also missing its pad.
Will you try American Mustard this time?
__________________
Michel

1978 W116 690SEL # 3312
1985 R107 500SL AMG
2000 C208 CLK430
Reply With Quote
  #62  
Old 30th May 2019, 04:46 PM
c107's Avatar
c107 c107 is offline
Aristocrat
 
Join Date: Jul 2013
Location: Sydney
Posts: 1,643
Default Re: 560sec ece

Quote:
Originally Posted by Michel View Post
Will you try American Mustard this time?
It may be too runny to attach to the vertical bonnet. And a French grain mustard would probably mean the seeds interfere with the adhesion.
__________________
Bryce
http://www.classicjalopy.com
Reply With Quote
  #63  
Old 30th May 2019, 05:59 PM
Michel's Avatar
Michel Michel is offline
The Prince of Arabia
 
Join Date: Feb 2008
Location: Sydney, Australia
Posts: 8,951
Default Re: 560sec ece

Quote:
Originally Posted by c107 View Post
It may be too runny to attach to the vertical bonnet. And a French grain mustard would probably mean the seeds interfere with the adhesion.
I guess you have 2 points there!
__________________
Michel

1978 W116 690SEL # 3312
1985 R107 500SL AMG
2000 C208 CLK430
Reply With Quote
  #64  
Old 2nd June 2019, 08:18 PM
SEL_69L's Avatar
SEL_69L SEL_69L is offline
Aristocrat
 
Join Date: Feb 2009
Location: Sydney, NSW, Australia
Posts: 1,263
Default Re: 560sec ece

Wheel offset within spec. for both cars?
Reply With Quote
  #65  
Old 2nd June 2019, 08:35 PM
c107's Avatar
c107 c107 is offline
Aristocrat
 
Join Date: Jul 2013
Location: Sydney
Posts: 1,643
Default Re: 560sec ece

Quote:
Originally Posted by SEL_69L View Post
Wheel offset within spec. for both cars?
Yes, I made sure of that. I drove a w126 with wrong offset wheels. it tramlined terribly and was unpleasant to ride in.
__________________
Bryce
http://www.classicjalopy.com
Reply With Quote
  #66  
Old 7th August 2019, 03:15 PM
c107's Avatar
c107 c107 is offline
Aristocrat
 
Join Date: Jul 2013
Location: Sydney
Posts: 1,643
Default Re: 560sec ece

I went away for a long weekend to the blue mountains and took the 560SEC. I've now got about 2,200km on it and it has performed well. There is plenty of power up some of those long sweeping turns near the top of bells line of road. The new tyres and wheels no longer shudder at speed and the engine is very smooth.

short term on the list to fix is the transmission leak, which is hopefully an o-ring in the bowden cable attachment.
__________________
Bryce
http://www.classicjalopy.com
Reply With Quote
  #67  
Old 1st September 2019, 08:09 PM
c107's Avatar
c107 c107 is offline
Aristocrat
 
Join Date: Jul 2013
Location: Sydney
Posts: 1,643
Default Re: 560sec ece

I've been meaning to flush the SLS since I got the car. I did it today, along with the 300SE.

The fluid was worse than it looked, once you get it into a clear bottle.


__________________
Bryce
http://www.classicjalopy.com
Reply With Quote
  #68  
Old 14th September 2019, 05:30 PM
c107's Avatar
c107 c107 is offline
Aristocrat
 
Join Date: Jul 2013
Location: Sydney
Posts: 1,643
Default Re: 560sec ece

Today my job is to replace the dented lower pan...

I took off the lower pan, and as expected I found a piece of broken guide in there. One of the guides was broken when I had the chain done a few months back.
What I didn't expect was to find a large lipped washer.
Does anyone know what it is?
There was no gasket on the pan, just some black sealer that wasn't sealing all that well.
There was also some small pieces of broken black plastic.




From what I can see, no damage from the dented pan?



Engine looks suspiciously clean. I wonder if it has been out? Engine number matches data card.



Dented pan before removal:

__________________
Bryce
http://www.classicjalopy.com
Reply With Quote
  #69  
Old 14th September 2019, 05:52 PM
c107's Avatar
c107 c107 is offline
Aristocrat
 
Join Date: Jul 2013
Location: Sydney
Posts: 1,643
Default Re: 560sec ece

as I started cleaning the surfaces, I also notice there has been scoring on the upper pan, you can see to the right hand side of the oil pump as you're standing in front of the car and rear of oil pump.
I wonder how that got there?



__________________
Bryce
http://www.classicjalopy.com
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
560SEC 6.9 for sale Oversize TRADING POST/EBAY LISTINGS 22 12th July 2014 12:49 AM
Very nice 560SEC AMG motec 6.9 TALKING TORQUE 2 3rd July 2014 07:15 PM
560SEC 6L 32V Widebody Oversize TALKING TORQUE 23 5th June 2014 02:03 PM
Nice 560sec motec 6.9 TRADING POST/EBAY LISTINGS 2 2nd June 2014 10:07 AM
560sec - Amg SELfor50 MERCEDES W126 3 1st May 2008 11:57 AM


All times are GMT +10. The time now is 07:02 PM.


Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright Topklasse 2017